
Le logiciel MSA pas à pas
Mode analyseur de spectre

12/12/09

Ce document est destiné à vous familiariser avec les fonctions de base du MSA et de 
son logiciel,  fonctionnant en mode analyseur de spectre,  sans que vous disposiez 
physiquement du MSA. Il vous suffit d'avoir installé le logiciel selon les instructions de 
Scotty.

Configuration matérielle

1 – Double-cliquez sur l'icône du logiciel MSA

2  –  Le  logiciel  s'exécute,  et  ouvre  le  "Configuration  Manager"  (gestionnaire  de 
configuration). Si vous avez déjà exécuté le logiciel, vous devrez ouvrir le menu Setup 
=> Hardware Config Manager (Gestionnaire de configuration matérielle)

3 – Sur le côté droit, la boîte de dialogue filtre final contient un filtre par défaut. 
Ajoutez-en un autre en tapant "10.6" dans le champ "Freq", puis "30" dans le champ 
"BW"  et  en  cliquant  sur  "Add"  (Ajouter).  Cela  ajoute  un  filtre  dont  la  fréquence 
centrale est 10,6 Mhz et la bande passante 30 kHz. Normalement, c'est ici que vous 
devrez entrer les données des filtres dont vous disposez réellement.

4 – Cliquez sur "Save Configuration". Le logiciel se ferme.

Fonctionnement en mode analyseur de spectre

1 – Double-cliquez sur l'icône du logiciel MSA. Attention : vous pouvez redimensionner 
la fenêtre du graphe du MSA, mais vous devez être sûr que le balayage est arrêté 
(cliquez sur "Halt") auparavant. Redimensionner pendant qu'un balayage est en cours 
vous donne une chance sur deux de "planter" le programme en raison d'un bug de 
Liberty Basic.

2 – Le logiciel s'ouvrira en mode analyseur de spectre (SA), à moins que vous n'ayez 
préalablement changé le  mode de  préférence.  Dans ce cas,  sélectionnez le  menu 
Mode => SA pour l'obtenir.

3 – Le graphe sera mis à jour comme si le logiciel commandait réellement l'analyseur, 
mais les données générées sont sans intérêt.

4 – Cliquez sur "Halt". Le MSA s'arrête, un marqueur triangulaire est placé sur l'axe 
des fréquences à la position du dernier pas, et des informations sur ce pas du graphe 
apparaissent sous la fenêtre. Cliquez sur Continue pour reprendre le balayage, ou 
cliquez sur One Step pour balayer le pas suivant et s'arrêter.

5 – Ouvrez la fenêtre des paramètres de balayage en double-cliquant sous l'axe des 
fréquences,  ou  en utilisant  le  menu Options  => Balayage.  Cette  fenêtre  contient 
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beaucoup d'options qui contrôlent le balayage.

6 – Dans la boîte de dialogue "Data Mode", sélectionnez l'élément n°5 (signal carré à 
1 Mhz). Cela génèrera des données à visualiser.

7  –  A  l'extrême  droite,  cliquez  sur  la  boîte  de  dialogue  Start/Stop.  Entrez  une 
fréquence de départ de 0 Mhz et une fréquence d'arrêt de 10 Mhz.

8 – Dans la boîte de dialogue Steps/Sweep (nombre de pas par balayage), entrez 200.

9 – Cliquez OK. La fenêtre se ferme. Si vous aviez arrêté l'analyse, cliquez sur Restart 
(Redémarrer). Cliquez ensuite sur "Halt at End" (Arrêter à la fin). A la fin du balayage 
en cours, le MSA s'arrêtera. Un graphe similaire à celui-ci sera visible :

Votre axe sera peut-être sur le côté droit. Si vous voulez changer cela, utilisez le 
menu Setup => Primary Axis (Configuration => Axe Primaire). Le graphe montre le 
spectre d'un signal carré à 1 Mhz idéal. La fondamentale est à 0dBm; il n'y a pas 
d'harmoniques pairs, et les harmoniques impairs décroissent en 1/N, en accord avec 
la règle. Le bas du graphe montre un bruit artificiel.

10 – Ouvrez à nouveau la fenêtre "Sweep Parameters" (Paramètres de Balayage) et 
changez  la  gamme  de  fréquence.  Cliquez  d'abord  sur  la  boîte  de  dialogue 
"Center/Span" (Fréquence centrale/Etendue). Entrez une fréquence centrale de 3 Mhz 
et un span (bande visualisée) de 0,1 Mhz. Fermez la fenêtre et cliquez sur "Restart" 
(Redémarrer). Vous obtiendrez un graphe identique au suivant :
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Ce graphe montre l'harmonique à 3 Mhz. Sa largeur est approximativement celle de la 
bande passante du dernier filtre FI, et sa forme correspond au profil de ce filtre. Ici, 
bien sûr, le profil est artificiel.

11 -  Double-cliquez sur le pic, et le marqueur L sera placé. La valeur du pic sera 
affichée sous le graphe dans la zone des "infos marqueurs". Ce sera -9,542 dBm, ce 
qui représente, en tension, le tiers du niveau de la fondamentale, dont le pic est à 0 
dBm.

12  –  Vous  pouvez  sélectionner  n'importe  quel  autre  marqueur  dans  la  boîte  de 
dialogue "Marqueurs" en bas, à gauche de la fenêtre du graphe. Quand vous double-
cliquez sur le graphe, le marqueur sélectionné apparaît. Il est placé sur la trace, à la 
fréquence sur laquelle vous avez cliqué, sauf les marqueurs P+ et P- qui iront se 
placer aux fréquences correspondant respectivement aux maximum et minimum du 
graphe. "Delete" (Supprimer) effacera le marqueur courant. Cliquer sur les boutons + 
ou  –  incrémente  ou  décrémente  le  marqueur  vers  le  pas  suivant  ou  précédent. 
Inscrire une fréquence dans le champ "Fréquence" et cliquer sur Entrée placera le 
marqueur à cette fréquence (sauf les marqueurs P+ et P- que vous ne pouvez pas 
déplacer).

13 – Sélectionnez, dans la boîte marqueurs, un des marqueurs numérotés et double-
cliquez n'importe où, dans le bruit, sur le graphe. Cliquez Continue ou Restart s'il est 
nécessaire de reprendre l'analyse. La position du marqueur sera mise à jour à la fin de 
chaque analyse.

14 – Cliquez sur "Clear Markers" pour effacer tous les marqueurs. Sélectionnez alors 
le menu Functions => Filter Analysis (Fonctions => Analyse de filtre). Une fenêtre 
s'ouvre, contenant plusieurs options; cliquez seulement sur OK. Des marqueurs sont 
ajoutés sur le pic et aux points à -3 dB, comme si le pic représentait la courbe de 
réponse d'un filtre :
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Notez que la  largeur de bande à -3dB est  affichée dans la  boîte.  Ce devrait  être 
approximativement la bande passante du filtre FI final courant. En mode analyseur de 
spectre, une raie étroite provoque une réponse pour toute fréquence d'accord proche 
de moins de la moitié de la bande passante du filtre FI, et même un peu à l'extérieur 
de cette bande. L'image résultante est donc similaire à celle que vous obtiendriez en 
utilisant un analyseur de spectre et un générateur de tracking pour analyser un filtre 
externe.

15 – Ouvrez la fenêtre "Sweep Parameters" (paramètres de balayage). Sur le côté 
gauche se trouve une liste de filtres FI finaux. Choisissez-en un différent et fermez la 
fenêtre. Cliquez sur Restart (Redémarrer). Si vous avez choisi un filtre plus large, le 
pic affiché est plus large et le niveau de bruit augmente. Si vous choisissez un filtre 
plus étroit, l'effet est opposé.

16  –  Ouvrez  le  menu  "Functions  =>  Filter  Analysis"  et  décochez  la  case  pour 
désactiver l'analyse de filtre. Cliquez sur OK. Les marqueurs restent, mais peuvent 
être réinitialisés en cliquant sur "Clear Markers" (Réinitialiser les Marqueurs).

17 – Ouvrez la fenêtre "Sweep Parameters" (Paramètres de Balayage), et changez la 
gamme  de  fréquence.  Cliquez  sur  la  boîte  de  dialogue  Start/Stop,  entrez  une 
fréquence de départ de 0,1 Mhz et une fréquence d'arrêt de 10,1 Mhz. Dans le champ 
Steps/Sweep, entrez 50. Fermez la fenêtre et redémarrez.

18 – Le graphe ne contient maintenant que du bruit  et on ne voit  aucun pic. Le 
message d'avertissement vous dit  exactement ce qu'il  se passe :  le  MSA fait  des 
mesures  sur  un nombre  discret  de  pas,  et  il  est  possible  qu'un signal  se  trouve 
entièrement entre  deux pas. A chaque pas,  le MSA détecte les signaux dans une 
certaine largeur de bande autour de la fréquence du pas, largeur égale à celle de la FI 
finale. Ici, tous les pics tombent entre deux pas.
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19 – Ouvrez la fenêtre "Sweep Parameters", changez la fréquence de départ à 0 Mhz 
et  la  fréquence  d'arrêt  à  10 Mhz.  Fermez la  fenêtre  et  si  nécessaire,  cliquez  sur 
Restart.  Toutes les raies représentant la fondamentale et les harmoniques sont de 
nouveau visibles.

Ajout d'un temps d'attente

1  –  Si  vous  n'avez  pas  atteint  cet  endroit  après  avoir  suivi  toutes  les  étapes 
précédentes,  ouvrez  la  fenêtre  "Sweep  Parameters"  (Paramètres  de  Balayage)  et 
réglez la fréquence de départ à 0, la fréquence d'arrêt à 10 MHz et le nombre de pas 
par balayage à 50. Sélectionnez également l'élément n°5 dans la boîte de dialogue 
"Data Mode". Fermez la fenêtre.

2 – Ouvrez la fenêtre "Sweep Parameters" (Paramètres de Balayage). Dans le champ 
"Wait Time" (Temps d'attente), entrez 50. Fermez la fenêtre et reprenez l'analyse. Elle 
est maintenant plus lente, car le MSA attend 50 ms après chaque pas pour permettre 
à la mesure de se stabiliser. Bien sûr, cela n'a aucun effet sur des données simulées, 
mais  lorsqu'on utilise  un filtre video efficace,  il  est nécessaire  d'ajouter un temps 
d'attente pour permettre aux données filtrées de se stabiliser à leurs valeurs finales. 
Sans ce temps d'attente, le graphe sera perturbé; cela peut par exemple provoquer le 
décalage d'une raie vers la droite.

3 – Si le temps d'attente est de plus de 15 ms, le logiciel entre brièvement en mode 
"veille", pendant approximativement la durée spécifiée. Cela libère du temps pour un 
autre  logiciel.  Cela  peut  également  permettre  au  processeur  de  passer  en  mode 
"basse  consommation",  économisant  ainsi  la  charge  de  la  batterie  de  l'ordinateur 
portable.

Changer la direction du balayage

1  –  Si  vous  n'avez  pas  atteint  cet  endroit  après  avoir  suivi  toutes  les  étapes 
précédentes,  ouvrez  la  fenêtre  "Sweep  Parameters"  (Paramètres  de  Balayage)  et 
réglez la fréquence de départ à 0, la fréquence d'arrêt à 10 MHz et le nombre de pas 
par balayage à 50. Sélectionnez également l'élément n°5 dans la boîte de dialogue 
"Data Mode". Fermez la fenêtre.

2 – Ouvrez la fenêtre "Sweep Parameters" (Paramètres de Balayage). Assurez-vous 
que le temps d'attente est réglé à 0. Dans la boîte de dialogue "Balayage", sur le côté 
droit,  cliquez sur  "Alternate"  (Alternatif)  de façon à alterner  le  sens du balayage. 
Fermez la fenêtre.

3 – Reprenez l'analyse par "Continue" ou "Restart". Le balayage va reprendre dans les 
deux sens. Ceci est utile pour l'analyse de circuits sujets à une hystérésis. C'est aussi 
une bonne façon de vérifier que votre temps d'attente est suffisant pour le filtre video 
sélectionné.  Lorsque vous observez  une raie  en alternant  le  sens du balayage,  le 
moindre décalage provoqué par un temps d'attente inapproprié sera inversé lors du 
changement de sens et deviendra évident.

4 – Ouvrez la fenêtre "Sweep Parameters". Sélectionnez le sens du balayage "L-R" 
(gauche droite) pour un balayage normal. Fermez la fenêtre.

5



Changer  l'apparence du graphe

1  –  Si  vous  n'avez  pas  atteint  cet  endroit  après  avoir  suivi  toutes  les  étapes 
précédentes,  ouvrez  la  fenêtre  "Sweep  Parameters"  (Paramètres  de  Balayage)  et 
réglez la fréquence de départ à 0, la fréquence d'arrêt à 10 MHz et le nombre de pas 
par balayage à 50. Sélectionnez également l'élément n°5 dans la boîte de dialogue 
"Data Mode". Fermez la fenêtre.

2 – Double-cliquez sur les étiquettes numériques de l'axe Y, de manière à ouvrir la 
fenêtre  de  configuration  de  l'axe  Y.  Plusieurs  options  vous  sont  présentées  qui 
contrôlent l'apparence du tracé du graphe. Choisissez une largeur de 3 et la couleur 
que  vous  voulez  (le  tracé  visible  ci-dessous  utilise  une  largeur  de  2).  Si  vous  le 
souhaitez,  changez  le  nombre  de  graduations  verticales.  Sous  "Trace  Style", 
sélectionnez "Histo Erase". Fermez la fenêtre. Le graphe sera redessiné et ressemblera 
à ceci :

L'histogramme est une bonne façon de représenter les harmoniques. Le nombre de 
pas  pourrait  même  être  réduit  pour  éliminer  le  bruit  intermédiaire.  Le  fait  que 
l'histogramme ne connecte pas les points est aussi une bonne façon de se rappeler 
que nous ne savons pas réellement ce qu'il  se passe entre les points d'analyse, à 
moins que la taille des pas ne soit assez petite pour interdire la disparition d'un signal 
entre les points d'analyse.

3 – Double-cliquez sur les étiquettes numériques de l'axe Y, de manière à ouvrir la 
fenêtre  de  configuration  de  l'axe  Y.  Dans  la  boîte  de  dialogue  "Trace  Style", 
sélectionnez "Histo Erase". Fermez la fenêtre. Si nécessaire, cliquez sur Restart pour 
continuer l'analyse. L'histogramme sera dessiné comme avant, mais à chaque analyse, 
les anciens histogrammes ne seront pas effacés. Cela n'aura aucun effet sur les pics, 
qui ont un niveau fixe. Mais pour le bruit, les barres de l'histogramme représenteront 
le  niveau  maximum de  toutes  les  analyses,  affichant  ainsi  effectivement  le  bruit 
maximum. Un effet similaire peut être obtenu avec le tracé normal en sélectionnant 
"Norm Stick".

4 – Ouvrez à nouveau la fenêtre de l'axe Y et sélectionnez "Trace Style Norm Erase". 
Sélectionnez 2 pour "Trace Width" (largeur de tracé). Fermez la fenêtre.
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5 – Ouvrez la  fenêtre  "Sweep Parameters"  (Paramètres de Balayage).  Entrez une 
fréquence de départ 1 MHz et une fréquence d'arrêt de 100 MHz. Sélectionnez "Log 
Sweep" (balayage logarithmique). Dans la boîte de dialogue "Data Mode", sélectionnez 
l'option  n°3  (Graph  Noisy  Sine).  Fermez  la  fenêtre  et  si  nécessaire,  cliquez  sur 
Restart. Le graphe montrera une sinusoïde erratique artificiellement générée à tous 
les points et qui par conséquent ne peut être changée. L'axe des fréquences aura une 
graduation  logarithmique.  L'avantage est  qu'un plus  grand nombre de points  sont 
consacrés aux fréquences basses, plutôt que de comprimer celles-ci dans une zone 
restreinte de la gauche du graphe. 

6 – Double-cliquez à l'extérieur de l'axe Y secondaire (celui qui, maintenant, n'a pas 
d'étiquettes). La fenêtre de l'axe Y s'ouvre. Dans la boîte de dialogue "Graph data", 
sélectionnez "Magnitude (Volts)". Fermez la fenêtre. Cet axe sera maintenant associé 
à un graphe de la magnitude du signal mesurée en volts. A cause de l'échelle par 
défaut, le graphe sera proche du bas. Ouvrez à nouveau la fenêtre de l'axe Y et entrez 
0.1  (ou  100m)  dans  le  champ  "Top  Ref".  Fermez  la  fenêtre.  Le  graphe  devrait 
ressembler à quelque chose comme ceci :

La  tension  (supposée  sur  50  ohms)  est  maintenant  tracée  selon  l'axe  droit  (le 
"Primary Axis" (Axe Primaire) est l'axe gauche), de 0 à 100 mV. Le graphe en dBm n'a 
pas changé.

7 – Double-cliquez sur ou au-dessus de l'étiquette "Date/Time" en haut du graphe. 
Une  fenêtre  s'ouvre  vous  permettant  d'introduire  trois  lignes  de  légende-titre. 
L'étiquette "Date/Time" (Date/Heure) est la troisième de cette légende. Vous pouvez 
entrer  autre  chose  dans  cette  troisième ligne,  mais  quand vous  redémarrerez,  la 
troisième ligne sera remplacée par une nouvelle étiquette "Date/Time".

8  –  Ouvrez  la  fenêtre  "Sweep  Parameters".  Dans  la  boîte  de  dialogue  "Graph 
Appearance"  (Apparence  du  Graphe),  sélectionnez  "Light".  Fermez  la  fenêtre. 
L'affichage se fera désormais en tracé sombre sur fond blanc. Les nouvelles couleurs 
de tracé prendront le pas sur les réglages précédents.

9 – Sélectionnez le  menu Options => Appearances (Option => Apparences).  Une 
fenêtre s'ouvre qui vous permet de choisir les couleurs d'arrière plan, de la grille et du 
cadre, du texte et des tracés. Choisissez ce que vous souhaitez et cliquez sur "Use". 
Vos  choix  sont  appliqués.  Si  vous  aviez  cliqué  "Save  as  preset"  (Sauver  comme 
Préréglage) au lieu de "Use", vous auriez eu la possibilité de sauver vos nouveaux 
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réglages de présentation sous un nom qui serait apparu dans la boîte de dialogue 
"Graph Appearances", dans la fenêtre "Sweep Parameters".

Sauvegarder les images et les données

1 – Sélectionnez Edit => Copy image. Une copie du graphe (sans les boutons du bas) 
est placée dans le presse-papiers. Vous pouvez ouvrir un traitement de texte ou un 
logiciel  de  retouche  d'images  et  coller  l'image  dans  ce  programme.  Vous  pouvez 
également  choisir  File  => Save  Image pour  sauver  celle-ci  sous forme de  fichier 
bitmap de votre choix. Certains programmes ne peuvent pas lire les fichiers bitmap 
créés par Liberty Basic, mais l'image du presse-papiers est universelle.

2 – Sélectionnez Data => Data Input. Une fenêtre s'ouvre affichant le numéro du pas, 
la  fréquence,  l'amplitude  du signal  en  dBm, plus  la  valeur  de  sortie  courante  du 
convertisseur analogique-digital ainsi que le facteur de correction utilisé par le MSA 
pour déterminer la magnitude du signal. Dans notre simulation, la valeur de sortie du 
convertisseur est toujours zéro. Nous n'avons pas fait de calibration, donc le facteur 
de correction est aussi zéro. En utilisant les menus de la fenêtre de données, vous 
pouvez les sauver dans un fichier ou bien les sélectionner et les copier pour les coller 
dans un autre programme tel qu'une feuille de calcul.

Sauvegarde des préférences

1 – Au démarrage du logiciel, les réglages initiaux proviennent d'un fichier nommé 
Prefs.txt. Vous pouvez remplacer ce fichier par les réglages courants en utilisant le 
menu  File  =>  Save  Prefs.  Si  vous  sauvez  vos  préférences  sous  Prefs.txt,  elles 
deviendront  vos  réglages  par  défaut  à  chaque démarrage  du logiciel.  Si  vous les 
sauvez sous un nom différent, vous pourrez les activer en utilisant le menu File => 
Load Prefs. Si vous avez changé un grand nombre de réglages et que vous souhaitez 
revenir aux réglages initiaux, vous pouvez le faire en utilisant File => Load Prefs pour 
recharger Prefs.txt.

2 – Si vous voulez restaurer le fichier original des préférences par défaut, vous pouvez 
le faire ainsi : quittez le logiciel, localisez le fichier Prefs.txt, effacez-le et redémarrez 
le programme. Un nouveau fichier Prefs.txt sera créé. Le chemin de ce fichier est :

(nom_du_dossier_MSA)\\MSA_Info\\MSA_Prefs\\Prefs.txt
où (nom_du_dossier_MSA) est le nom du dossier où vous avez installé le logiciel MSA.

Sessions multiples du logiciel

1 – Double-cliquez sur l'icône du logiciel MSA pour le lancer. Cliquez sur Halt.

2 – Double-cliquez de nouveau sur l'icône pour ouvrir une seconde session du logiciel. 
Cliquez sur Halt.

3 – Vous avez désormais deux fenêtres de graphe. Vous pouvez régler les gammes de 
fréquence  et  les  autres  options  de  chaque  fenêtre  indépendamment.  Les  seules 
restrictions sont :

(1)– d'éviter les confusions au niveau matériel. Vous devez cliquer sur Halt 
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dans une fenêtre avant de faire fonctionner l'autre.
(2)- tous les changement que vous apporterez aux fichiers, comme sauver 

les  préférences,  affectera  les  deux  fenêtres,  car  les  fichiers  sont 
communs à ces deux fenêtres

4 – Pour rendre les fenêtres plus indépendantes, vous pouvez copier le dossier entier, 
contenant le logiciel et les fichiers, et lancer les copies du logiciel séparément. Dans 
ce cas, chacune disposera de ses propres fichiers.

5 – C'est une façon utile de "monitorer" deux bandes de fréquences différentes. Notez 
qu'à l'heure actuelle,  le  MSA ne dispose pas d'une commutation automatique des 
filtres. De sorte que si les deux balayages utilisent des résolutions ou des filtres video 
différents,  les  filtres  doivent  être  changés  manuellement  avant  de  passer  d'un 
balayage à l'autre.

L’original de ce texte est disponible à l’adresse

http://www.wetterlin.org/sam/SA/Operation/MSA_Walkthrough_SA.pdf

L’intégralité des manuels et didacticiels sont accessibles à l’adresse

http://www.wetterlin.org/sam/

Le contenu de ce texte ne peut être modifié sans l’autorisation de son auteur. Traduction f1hsu sous Creative Commons
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